IETF

Available (40)

Showing 1 - 12 per page



IETF Draft Quantum-Native Architectural Tenets and Philosophy for the Quantum Internet

IETF Draft: Quantum-Native Architectural Tenets and Philosophy for the Quantum Internet  

draft-cacciapuoti-qirg-quantum-native-architecture-01

 

  This document extends RFC 9340 by outlining a set of quantum-native architectural tenets for the design and evolution of the Quantum Internet.  These principles should not be interpreted as dogmas, but as pragmatic guidelines and criteria for harnessing the unique properties of quantum entanglement within networked systems.  Such design perspectives, while departing from the classical Internet, remain aligned with a foundational insight: the principle of constant change, articulated in RFC 1958.

   The document specifies quantum-native extensions to the Quantum  Internet framework, defining an entanglement packet switching paradigm and an explicit separation between the Quantum Data Plane and Quantum Control Plane.  It introduces Quantum Internet Addressing to extend quantum semantics into control and coordination, and generalizes the classical forwarding concept to quantum packets.


 

IETF RPL DIS Modifications and Applications

IETF RPL DIS Modifications and Applications (draft-ietf-roll-dis-modifications-02)

This document augments [RFC6550] by defining new DODAG Information Solicitation (DIS) flags and options that enable a RPL node to exert finer control over how neighboring RPL routers respond to its DIO solicitations. In addition, this document describes several use cases that motivate these DIS extensions and illustrate scenarios in which enhanced control of DIO responses improves network efficiency, responsiveness, and robustness.

 

IETF ROLL Common Ancestor Objective Function and Parent Set DAG Metric Container Extension

Common Ancestor Objective Function and Parent Set DAG Metric Container Extension
draft-ietf-roll-nsa-extension-14

High reliability and low jitter can be achieved by being able to send   data packets through multiple paths, via different parents, in a   network.  This document details how to exchange the necessary   information within RPL control packets to let a node better select   the different parents that will be used to forward a packet over   different paths.  This document also describes the Objective Function   which takes advantage of this information to implement multi-path   routing.

Dirk Kutscher

Description of Activities

Chair at the Internet Research Task Force (IRTF)

Country
Germany
Fellow's country
Open Call Topics
Open Call
Organisation type
Organization
University of Applied Sciences Emden/Leer
Portrait Picture
picture
Role in SDO
Standards Development Organisation
Topic
5G and beyond
StandICT.eu Year
2029
Year

Per Andersson

Country
Sweden
Fellow's country
Open Call
Organisation type
Organization
Ionio Systems Sweden AB
Portrait Picture
picture
Role in SDO
Standards Development Organisation
StandICT.eu Year
2029
Year
Topic (2nd Open Call)

Polyzois Soumplis

Country
Greece
Fellow's country
Open Call Topics
Open Call
Organisation type
Organization
ICCS/NTUA
Portrait Picture
Soumplis
Proposal Title
Telemetry and KPI semantics for closed-loop edge-cloud orchestration
Standards Development Organisation
Topic
Cloud and Edge Computing
StandICT.eu Year
2029
Year

Framework for Energy Efficiency Management (IETF -green-framework-02)

   Recognizing the urgent need for energy efficiency, this document   specifies a management framework focused on networks, devices and   device components within, or connected to, interconnected systems.   The framework aims to enable energy usage optimization, based on the   network condition while achieving the network's functional and   performance requirements (e.g., improving overall network   utilization) and also ensure interoperability across diverse systems.   Leveraging data from existing use cases, it delivers actionable   metrics to support effective energy management and informed decision-   making.  Furthermore, the framework defines mechanisms for   representing and organizing timestamped telemetry data using YANG   data models and metadata, enabling transparent and reliable   monitoring.  This structured approach facilitates improved energy   efficiency through consistent energy management practices.

A YANG Module for Entitlement Inventory (IETF-ivy-entitlement-inventory-04)

This document defines a YANG data model for managing software-based   entitlements (licenses, authorization tokens, pay-as-you-go service   credentials…) within a network inventory.  The model represents the   relationship between organizational entitlements, network element   capabilities, and the constraints that entitlements impose on   capability usage.   This data model enables operators to determine what capabilities   their network elements possess, which capabilities are currently   entitled for use, and what restrictions apply.  The model supports   both centralized entitlement management and device-local entitlement   tracking for physical and virtual network elements.

Terminology for Energy Efficiency Network Management (IETF green-terminology-02)

 Energy-efficient network management is primarily meant to enhance   conventional network management with energy-related management   capabilities that optimize overall network energy consumption.  To   that aim, specific features and capabilities are required to control   (and thus optimize) the energy use of involved network elements and   their components.   This document defines a set of key terms used within the IETF when   discussing energy efficiency in network management.  Such reference   document helps framing discussion and agreeing upon a set of main   concepts in this area.